26 Sep

Windows Server 2003 – CD 2 in das Setup integrieren

Unter diesem Link des Microsoft Technets, erfährt man wie man die 2. CD vom Window Server 2003 in das RIS „migriert“.

http://technet2.microsoft.com/WindowsServer/en/library/0c7a22fc-317a-43fb-9b85-18acfd65f2831033.mspx?mfr=true

Da ich da bei der Installation aber gleich mal eine Fehlermeldung erhalten habe, werde ich dann posten wie es wirklich funktioniert. Microsoft und seine Anleitungen 🙁

EDIT:
Die Anleitung von Microsoft funzt, bist zu dem Punkt wofür man die Anleitung braucht (also wie immer).
Gebt am besten in der [GuiRunOnce] folgenden Befehl ein und vergesst den von der Anleitung:
Command0=“%systemdrive%\sysprep\todo.bat“

Diese Datei muss natürlich vorhanden sein. Tragt dort dann alles ein, was der Client bei der 1. Anmeldung machen soll. Wie zum Beispiel die Integration der CD2.

Hierzu muss folgender Eintrag in die todo.bat: %systemdrive%\R2\setup2.exe /q

(Voraussetzung: Ihr habt von der CD 2 den Inhalt von Components/R2/ nach $OEM$/$1/r2 kopiert)

22 Sep

RIS Server – Die Lösung

Abgesehen davon, dass ich mich entschlossen habe alle Controllertreiber in ein einziges Windows Setup zu integrieren und hiervon zu installieren, habe ich nun die Lösung für das Problem mit dem RIPREP Image. Man muss beim Image angeben, dass er nach bzw. bei der Installation nach Nicht-Plug-und-Play fähigen Geräten sucht. Ansonsten kommt der besagte Bluescreen.

Heute habe ich erneut versucht bei Microsoft einen Call zu machen. Er sollte mir lediglich mitteilen wie man die 2. Setup CD des Windows Servers 2003 RC2 (ja der hat 2 CDs) in das RIS integriert. Auch hier war der gute Herr (darf sich immerhin System Engineer schimpfen) völlig überfordert.

Die 64bit Treiber lassen sich nach wie vor nicht in ein Windows Setup integrieren. Aber natürlich war der System Engineer auch hier total überfordert.

Was können die eigentlich ausser schlecht programmieren?

18 Sep

RIS Server – (kleine) Probleme

Ich bin zur Zeit dabei einen RIS Server aufzusetzen. Es sieht so aus als könnte Windows nicht richtig mit Treiber umgehen. Im Textmodus bindet er die Controllertreiber ein. Er sollte sich dann anschließend aus dem $OEM$ Verzeichnis die Treiber für den GUI Mode holen und installieren. Leider bricht der RIS hier ab. Aus der Setup Routine funktioniert es. Sobald ich ein RIPREP Image installiere, das einen anderen Controller enthielt installiert er nur im Textmodus. Anschließend der Bluescreen. Microsoft hat natürlich wieder mal keine Ahnung. Jedenfalls nicht ohne dafür ne Menge Geld zahlen zu müssen….