27 Jan

Hurra – Installieren wir neu

Da der „super“ Support von meinem Hoster ganz „versehentlich“ alle Config Dateien gelöscht hat, als er die Festplatte wechselte und den Rebuild des RAID Arrays durchführte, konnte ich jetzt den ganzen Server neu aufsetzen. Ich richte gerade sämtliche Domains wieder ein. Stelle die Datenbanken wieder her und konfiguriere die Mailboxen.

Schöne Beschäftigung. Das ganze Wochenende für die Katz….

26 Jan

Ausfall HDD

Heute ist mir eine Festplatte des Webservers ausgefallen. Gut dass dieser ein RAID 1 besitzt.

Als ich heute morgen den Blog checken wollte, war der Server nicht erreichbar. Nach einem Reboot hakte er und stürzte andauernd ab. Ich checkte die Logs. Nichts zu sehen. Nach dem 3. Reboot war in den Logs dann endlich was drin:

Jan 26 08:44:39 delta419 kernel: Additional sense: Unrecovered read error – auto reallocate failed
Jan 26 08:44:39 delta419 kernel: end_request: I/O error, dev sda, sector 17552140
Jan 26 08:44:39 delta419 kernel: ata1: status=0x51 { DriveReady SeekComplete Error }
Jan 26 08:44:39 delta419 kernel: ata1: error=0x40 { UncorrectableError }
Jan 26 08:44:39 delta419 kernel: ata1: status=0x51 { DriveReady SeekComplete Error }
Jan 26 08:44:39 delta419 kernel: ata1: error=0x40 { UncorrectableError }
Jan 26 08:44:39 delta419 kernel: ata1: status=0x51 { DriveReady SeekComplete Error }
Jan 26 08:44:39 delta419 kernel: ata1: error=0x40 { UncorrectableError }
Jan 26 08:44:39 delta419 kernel: ata1: status=0x51 { DriveReady SeekComplete Error }
Jan 26 08:44:39 delta419 kernel: ata1: error=0x40 { UncorrectableError }
Jan 26 08:44:39 delta419 kernel: ata1: status=0x51 { DriveReady SeekComplete Error }
Jan 26 08:44:39 delta419 kernel: ata1: error=0x40 { UncorrectableError }
Jan 26 08:44:39 delta419 kernel: sd 0:0:0:0: SCSI error: return code = 0x8000002
Jan 26 08:44:39 delta419 kernel: sda: Current: sense key: Medium Error
Jan 26 08:44:39 delta419 kernel: Additional sense: Unrecovered read error – auto reallocate failed
Jan 26 08:44:39 delta419 kernel: end_request: I/O error, dev sda, sector 17552148
Jan 26 08:44:39 delta419 kernel: md: syncing RAID array md0
Jan 26 08:44:39 delta419 kernel: md: minimum _guaranteed_ reconstruction speed: 1000 KB/sec/disc.
Jan 26 08:44:39 delta419 kernel: md: using maximum available idle IO bandwidth (but not more than 200000 KB/sec) for reconstruction.
Jan 26 08:44:39 delta419 kernel: md: using 128k window, over a total of 104320 blocks.
Jan 26 08:44:39 delta419 kernel: RAID1 conf printout:
Jan 26 08:44:39 delta419 kernel: — wd:1 rd:2
Jan 26 08:44:39 delta419 kernel: disk 0, wo:0, o:1, dev:sdb3
Jan 26 08:44:39 delta419 kernel: disk 1, wo:1, o:0, dev:sda3
Jan 26 08:44:39 delta419 kernel: RAID1 conf printout:
Jan 26 08:44:39 delta419 kernel: — wd:1 rd:2
Jan 26 08:44:39 delta419 kernel: disk 0, wo:0, o:1, dev:sdb3
Jan 26 08:44:39 delta419 kernel: md: delaying resync of md1 until md0 has finished resync (they share one or more physical units)
Jan 26 08:44:42 delta419 kernel: md: md0: sync done.
Jan 26 08:44:42 delta419 kernel: md: syncing RAID array md1
Jan 26 08:44:42 delta419 kernel: md: minimum _guaranteed_ reconstruction speed: 1000 KB/sec/disc.
Jan 26 08:44:42 delta419 kernel: md: using maximum available idle IO bandwidth (but not more than 200000 KB/sec) for reconstruction.
Jan 26 08:44:42 delta419 kernel: md: using 128k window, over a total of 77031552 blocks.
Jan 26 08:44:42 delta419 kernel: md: md1: sync done.
Jan 26 08:44:42 delta419 kernel: RAID1 conf printout:
Jan 26 08:44:42 delta419 kernel: — wd:2 rd:2
Jan 26 08:44:42 delta419 kernel: disk 0, wo:0, o:1, dev:sdb1
Jan 26 08:44:42 delta419 kernel: disk 1, wo:0, o:1, dev:sda1
Jan 26 08:44:42 delta419 kernel: RAID1 conf printout:
Jan 26 08:44:42 delta419 kernel: — wd:1 rd:2
Jan 26 08:44:42 delta419 kernel: disk 0, wo:0, o:1, dev:sdb3

Und weg war die Festplatte. Der Support benötigte für die Erfassung des Problems ca 4 Stunden. Nach einer weiteren Stunde war die Festplatte getauscht, das RAID rebuildet und der Server lief wieder.

24 Jan

Toll gemacht Bill

Microsoft arbeitet bereits an einem Service Pack 1 für Windows Vista. Dieses soll im 2. Halbjahr 2007 erscheinen.
Windows Vista wurde als sicherste Out-Of-The-Box Lösung angepriesen, ist bei uns noch nicht offiziell erhältlich und braucht bereits ein Service Pack?
Toll gemacht Bill!

18 Jan

Neulich an der Support Hotline….

Das Telefon klingelt. Anbei der Gesprächsverlauf.

Kunde: Hallo. Ich bräuchte Hilfe beim tauschen einer CPU.
Ich: Kein Problem. Welches Problem haben Sie?
Kunde: Ich habe den Passivkühler abgeschraubt und herausgezogen. Dabei ist die CPU daran hängen geblieben. Diese klebt so fest, dass ich sie nicht losbekomme.
Ich: Am besten Sie erwärmen den Passivkühlkörper. Mit einem Handfön oder ähnlichem.
Kunde: Ich bin hier im Rechenzentrum, die haben keinen Handfön.
Ich: Dann versuchen Sie den Kühlkörper mit der Heizung zu erwärmen und „schieben“ Sie die CPU mit leichten Drehbewegungen vom Kühlkörper.
Kunde: Danke ich werde sehen was ich machen kann….

[Ende des Telefonats]

Kurze Zeit später klingelt das Telefon erneut. Ich gehe ran:

Kunde: Hallo, ich nochmal.
Ich: Konnten Sie die CPU vom Kühlkörper lösen?
Kunde: Ich habe hier einen Herd, mit dem versuche ich es. Ich habe die CPU auf die Herdplatte gelegt….
Ich: Sie haben was?
Kunde: Ich meinte natürlich den Kühlkörper, entschuldigen Sie bitte.
Ich: Aber nur leicht anwärmen, nicht die CPU kochen.
Kunde: Keine Sorge, ich habe die Platte auf kleinster Stufe aufgedreht und lasse Sie nun 2-3 Minuten lang erwärmen.

Und so macht man sich eine gebratene CPU. Ich empfehle ein Glas trockenen Rotwein dazu.

Nachtrag:

Das Telefon läutete erneut. Wieder der selbe Kunde:

Kunde: Hallo, es hat alles geklappt. Nur jetzt hab ich beim booten eine komische Fehlermeldung.
Ich: Wie lautet die Fehlermeldung?
Kunde: Genau weiß ich sie nicht mehr, irgendwas mit PXE und media error. Cable check…
Ich: Sie versuchen gerade vom Netzwerk zu booten und der Server bemängelt ein fehlendes Kabel.
Kunde: Ach, gut. Dann steck ich jetzt das Kabel an und versuchs nochmal.